Showing posts with label public-policy. Show all posts
Showing posts with label public-policy. Show all posts

Monday, November 10, 2014

A lottery is a tax on... people who are good at reasoning about risk-adjusted returns?

Rescued from the drafts folder because John Oliver has rendered it timely.

People who consider themselves smart sometimes joke that a lottery is a tax on people who are bad at math.

The root of this reasoning is that the expected return on investment for a lottery ticket is negative. It can't help but be otherwise: the lottery turns a profit, hence the payout multiplied by the probability of winning must be less than the price of the ticket. Therefore, the reasoning goes, the people who buy lottery tickets must be incapable of figuring this out. Ha ha, let us laugh at the rubes and congratulate ourselves on our superiority.

One rejoinder is that the true value of a lottery ticket, to the buyer, is the entertainment value of the fantasy of winning. One obtains the fantasy with probability 1 and thus as long as the entertainment value of this fantasy exceeds the price of the ticket, the buyer comes out ahead.

There is something to this. But I think a stronger claim can be made.

A lottery is the mirror image of catastrophe insurance. Note that buying insurance also has a negative expected return. Provided their actuarial tables are accurate, insurance companies turn a profit. Therefore the probability of being compensated for your loss, multiplied by the compensation, must be less than the cost of the insurance premiums. But nobody says that insurance is a tax on people who are bad at math. Quite the opposite: buying insurance is viewed as a sign of prudence.

The issue, of course, is that the naive expected return calculation fails to adequately consider the nature of risk and catastrophe. At certain thresholds, financial consequences as experienced by human beings become strongly nonlinear, probably due to the declining marginal utility of money. Suffering complete ruin due to, say, a car accident entails such severe consequences that we are willing to accept a modestly negative expected return in exchange for the assurance that it will simply never occur.

A lottery is simply the flip side of this coin. The extremely rare event is a hugely positive one, instead of a hugely negative one, huge enough to produce qualitative rather than merely quantitative changes to your lifestyle. And one accepts a modestly negative expected return, not so that one can avoid the risk, but that one can be exposed to the risk.

If you are a member of the educated, affluent middle class, there is an excellent chance that your instinct rebels, and you're already hunting for the flaw in this reasoning. Surely there's something sad, and not prudent, about those largely working-class souls who buy a lottery ticket every week, rather than rolling that $52 per year into a safe index fund at a post-tax rate of return of roughly 2.5% per annum, at which rate their investment, if it somehow survived unperturbed the ups and downs of a life that is considerably more exposed to financial risk than a middle-class person's, might compound to the princely sum of a couple months' rent by the time they die, or alternatively enough to pay for a slightly nicer coffin.

And maybe there is a flaw in this reasoning. I'm not completely convinced myself and I'm not going to start buying lottery tickets. But I'm honestly having trouble finding the flaw. Any indictment of spending (small amounts of) money on lottery tickets must surely also apply to buying insurance. If it is worth overpaying a little bit to eliminate the possibility of a hugely negative outcome, surely it is worth overpaying a little bit to create the possibility of a hugely positive outcome. The situations are symmetric, and I think one can only break the symmetry by admitting the validity of loss-aversion (usually viewed as irrational by economists) or something similar.

Alternatively, if you have access to the actuarial tables of your insurance company, then perhaps you can argue that a lottery is, quantitatively, simply a worse deal than your insurance typically is... but you probably don't have access to those actuarial tables. And I sincerely doubt that the widespread middle-class snobbery towards lottery players is based on quantitative calculations of this sort. (Actually, I strongly suspect that it is based on a fallacious, gut-instinct "folk probability" feeling that gambling on any extremely remote event, like winning the lottery, is somehow inherently foolish.)

So what's the flaw? I ask this question non-rhetorically; that is, I am genuinely curious about the answer.


p.s. None of the above, of course, is to say that I think the taxation effect of lotteries, which is staggeringly regressive, is a good thing. I would strongly support the replacement of lotteries with progressive tax increases plus transfer payments! Gambling addiction is bad too. But these things seem distinct from the notion that playing the lottery in small amounts is irrational in some game-theoretic sense.

Sunday, October 21, 2007

Sullivan, Malkin, and justified belief

Henry at CT dares Andrew Sullivan to engage in substantive debate with Cosma Shalizi about statistics, which literally caused me to laugh out loud. Of course, the idea is ridiculous. Andrew Sullivan's a journalist with a Ph.D. in political philosophy, and I doubt he's done any math beyond basic arithmetic in decades. Like most elite journalists, he probably considers mathematics --- which is merely the language of the universe, after all --- unworthy of the hard work it would take to relearn it. Much easier to weave a bunch of tangentially related sophistry and hope your listeners get too distracted to notice you've simply evaded the main point.

On a similar note, Ezra Klein recently dared Michelle Malkin to debate him about health care. She ran away, of course. Ezra Klein is a huge policy nerd who spends his days reading white papers about health care. Malkin is a shrieking demagogue who spends her days copying and pasting Republican talking points and minimally digested links into her offal-trough of a blog. Nobody with half a brain earnestly believes that Malkin knows anything about health care policy. And Malkin has a enough of a vestigial sense of dignity (even after doing this) to fear being completely humiliated by Klein. Her refusal was a foregone conclusion.

A common thread unites these two stories. Shalizi and Klein have made conscious life choices that narrow their respective subjects of expertise (with sometimes steep costs), and as a consequence they can speak about those subjects with authority. People who make such sacrifices do so because they care about the subject, which is to say that they care about the truth of the matter. They want to get things right, and to behave in a way that causes their audiences to become strictly better-informed than before.

Sullivan and Malkin are playing a fundamentally different game. Their mission is to attract attention and notoriety. They do not care whether their actions further the cause of knowledge, by which I mean justified and true belief. In fact, in their own ways, Sullivan and Malkin behave professionally in ways that directly inhibit the propagation of knowledge. Not coincidentally, this behavior has salutary effects on their careers.

Sullivan does not care whether a belief is justified and true; or, at least, he does not care enough to approach any given subject with the humility and patience to learn about it. He earnestly believes that there's value to stirring up the waters, even if the primary effect is to splash mud into people's eyes. This belief is convenient for him in two ways. First, it gives him permission to write about anything without understanding its substance; and being prolific is good for a pundit's career. Second, it places him at the center of controversies; and being part of a controversy --- regardless of the correctness of one's positions --- is also good for a pundit's career.

Malkin, for her part, understands that (like Jonah Goldberg) her job is not to investigate the truth of anything, but to spew a great volume of noise that echoes the prevailing Republican talking points. I don't doubt that, on some level, Malkin believes whatever she's saying at any given moment. However, the distinction between knowledge and faith is that knowledge is justified --- that there exists some combination of evidence and inference that logically leads one to the conclusion. Malkin has chosen to base her career instead on faith --- and not even faith in a stable set of fundamental principles, which might be admirable, but faith in the official Party truth of the moment. (Eastasia? We have always been at war with Eastasia.) As a propagandist, Malkin's mission is faith through noise --- produce enough noise, and you can reinforce people's beliefs in the Party without ever justifying those beliefs. Obviously, this behavior is good for her career. The more noise you produce, and the more closely you adhere to the Party line, the more likely that people in the market for such noise will choose to pay attention to you.

Sadly, Sullivan and Malkin are well-rewarded for doing what they do. In politics, the market for knowledge is much weaker than the market for noise. Knowledge is expensive and serves only itself, but noise is cheap and can be turned to the purposes of any buyer. We can heap contempt on Sullivan and Malkin, but I don't know how to change the underlying dynamics that elevate them to prominence.

Tuesday, June 12, 2007

.sft: A proposal for software patent reform

As follows:

  1. Software companies that wish to protect their intellectual property register with a new ICANN gTLD, .sft.
  2. A .sft receives "IP points" every time it produces a "significant" software innovation. For example, every time a .sft publishes a peer-reviewed paper in a major computer science conference, that .sft gets 100 IP points.
  3. Any .sft may "sue" another .sft at any time, for any reason, for any quantity of money.
  4. Lawsuits are settled by best-of-7 tournaments of StarCraft. A .sft's designated StarCraft player ("IP lawyer") starts each match with a bonus quantity of minerals, Vespene gas, and peons determined by a time-weighted function of the .sft's IP points. The victor wins a fraction of their client's requested damages determined by the ratio of their buildings razed, units constructed, etc. vs. their opponents'.
  5. IP lawyers may play Protoss, Terran, Zerg, or random race, at their discretion.

The merits of this reform are obvious. Much like patent law, StarCraft is governed by a system of arcane rules that are mostly irrelevant to the actual process of writing innovative software. Much like patent law, StarCraft's rules can only be mastered by a caste of professionals whose expertise is honed over years of practice. Unlike the legal system, however, StarCraft is swift, decisive, objective, and exquisitely balanced for fairness. Any minor loss in the quality of judgment on the margin would be overwhelmed by the reduced transaction costs of the system as a whole.

I can already hear the objections of the closed-minded, and I will respond to them in turn.

  • Q: You're introducing perverse incentives. Companies with better StarCraft players will beat companies who write better software!
    A: Paying for quality StarCraft players would simply be a cost of doing business, no different from hiring secretaries or accountants or paying your electric bill. Even though the market value of Starcraft skills would temporarily skyrocket, StarCraft does not have a government-sanctioned professional guild that artificially limits the labor supply, so in the long run the cost would still be lower than for ordinary lawyers. Anyway, if some company hires bad StarCraft players, the management's incompetent and the company deserves to lose in the marketplace, regardless of how innovative their software developers are.
  • Q: What's to stop the emergence of "IP trolls" who never innovate, but hire a lot of expert StarCraft players to sue everyone?
    A: First, only companies with substantial independent revenue streams would be able to compensate StarCraft players well enough to attract really good ones. Second, beyond a certain point, the bonus resources granted by accumulated IP points would produce an overwhelming advantage for companies that produce innovation.
  • Q: Wouldn't this give an unstoppable advantage to software firms in South Korea, which has an impressive national lead in competitive StarCraft talent?
    A: So what? The international distribution of firms holding technology-related patents in the past two decades has not been even remotely equal. Established United States firms like IBM and Microsoft hold vast patent portfolios, dwarfing those of firms in developing nations, and WIPO has been aggressively working to bring developing nations under First World IP regimes. Yet the software industry remains steadfastly innovative around the globe. Over time, other nations would earn IP points and develop local StarCraft talent, evening the score. In any case, freezing the rules over an unequal or even larcenous initial distribution is the very essence of property: if a Native American robber breaks into your home and takes your television, will you refrain from pressing charges when he's arrested?
  • Q: Your proposal permits any .sft to sue any other .sft, without any basis for infringement. That's absurd!
    A: Under the present system, lawsuits claiming intellectual property infringement can drag on for years and cost millions of dollars even if the plaintiff never specifies exactly what was infringed upon. By permitting any .sft to challenge any other .sft, we remove the fig leaf of "cause of action", which (let's face it) is mostly just embarrassing. Also, as noted above, .sft lawsuits would be swift and decisive, so the transaction costs would be low even for frivolous lawsuits. That said, I am not completely opposed to a ladder system, to save highly skilled lawyers from being constantly challenged by lowbies.
  • Q: IP points would give an unstoppable advantage to entrenched encumbents with deep IP portfolios. What's to stop them from suing everyone?
    A: Under the present patent system, IBM, Microsoft, or any number of other entrenched players with deep patent portfolios could hypothetically destroy the entire software industry in a convulsive paroxysm of lawsuits. Yet they choose not to, because suing everyone in the industry would result in "mutually assured destruction": everyone would countersue everyone else and everyone would lose. I see no reason that .sft lawsuits would be any different.
  • Q: What's to stop incumbents from suing little startups that have lower-tier StarCraft players and few IP points?
    A: Startups today usually have small to nonexistent patent portfolios, but big companies don't find it worth their time to sue them because they also have very few assets worth confiscating. As a startup grows more successful and its pockets get deeper, it should be able to afford to hire StarCraft talent and accumulate IP points, just as companies today accumulate patents and other IP as they grow bigger.
  • Q: The software industry's incredibly innovative to date, and your reform would bring it under a radically new legal regime. How can you be sure it won't stifle innovation?
    A: How can you be sure it will stifle innovation? There's ZERO evidence that it would. Imagine if we'd listened to such naysayers back when software patents were proposed. Don't you think the burden of proof is on the opponents of regulation, rather than on the proponents?
  • Q: StarCraft 2 is coming out soon. How does that affect your proposal?
    A: StarCraft 2 is currently an unknown quantity, whereas Starcraft is a classic that has withstood the test of time. That said, we should keep an open mind about the gameplay innovations, and if they prove to be successful I am not opposed to adopting the sequel someday. For one thing, the improved graphical sophistication would make lawsuits more entertaining for bystanders to watch.
  • Q: Halo would be more exciting than Starcraft.
    A: Fuck off, frat boy.

Wednesday, January 24, 2007

Notes on [Hahn Litan 06]: Network Neutrality Part 1: Requests For Comments

[Full disclosure: I work for a large technology company that presently lobbies for network neutrality legislation. My personal views on network neutrality predate my employment, and are independent of it. Everything posted on this site reflects strictly my own thinking, and is not endorsed, sponsored, or approved by my employer in any way. Finally, this should go without saying, but nothing I write here reflects any confidential or proprietary information from my employer.]

The generally excellent Tim Lee @ TLF today writes two posts reacting to a recent white paper on network neutrality by R. W. Hahn and R. E. Litan of AEI/Brookings[0] (also to be published in the Milken Institute Review).

As I read it, Hahn and Litan's paper makes the following major claims. First, they claim that the Internet's not neutral, and never has been --- hence the title, "The Myth of Network Neutrality...". Second, they claim that existing proposed legislation to codify network neutrality into law would do more harm than good. Third, they claim that there are economic benefits to tiered pricing for network-layer "quality of service" (QoS).

The major weakness of the paper is that the authors do not understand Internet technology, and they seem to have consulted zero experts who do. As a result, they make many elementary errors of fact, rendering their argument unsound and their conclusions unsupportable. I am rather too tired tonight to go through all the errors at once, so I will delineate only a few in this post. Expect at least one follow-up post sometime in the next N days.

On Requests For Comment

Hahn and Litan cite several historical RFCs in support of the following conclusion:

. . . early writings on the Internet indicate that prioritization has always been considered an important design characteristic for TCP/IP --- sharp contrast to the romantic ideal of the end-to-end principle.

This post will examine how the authors attempt to support this claim, and how they fail.

As an aside, before I dive in, it is important to recognize that RFCs ("Requests For Comments") are not necessarily authoritative design documents for the Internet. RFCs have no binding force except insofar as many engineers independently decide to follow them --- a sort of community-based moral suasion, given economic force by network effects. Furthermore, RFCs vary widely in purpose: they may be arcane memos warning about one-time events, ideas of untested merit from the dustbin of history, cutting-edge research that may or may not ever be adopted, or even jokes.

Only a few RFCs describe protocols that have been widely implemented and deployed on the Internet, and even those are almost always provisional.

On to the meat. Hahn and Litan cite four RFCs. Tim seems to have missed read the short version of Hahn and Litan's paper, which lacks RFC citation numbers, but they're in the footnotes of the long version:

  • RFC 675: Specification of Internet Transmission Control Program
  • RFC 791: Internet Protocol
  • RFC 1633: Integrated Services in the Internet Architecture: an Overview
  • RFC 794: Pre-emption

The first two are (ancestors of) bona fide, widely-adopted standards. The third is a position paper by a group of highly respected networking researchers. So, those three RFCs are not jokes, although the first was superceded by RFC 793 before ARPANET even became the Internet, and the third has never, to date, been deployed on the Internet at all. Then there's the fourth, which does not even describe the Internet, but another network entirely; so it is not exactly a joke, but it's pretty funny to see it cited as evidence of the Internet's principles.

So, here are the mistakes the authors make w.r.t. each of these RFCs in turn. Note that I share Tim's frustration that the authors have not, in most cases, provided either page numbers or quotes, so in some cases I have had to interpolate the exact citation.

RFC 675

This RFC describes an early version of TCP, one of the two fundamental protocols of the Internet. The authors state that Vint Cerf "explained that outgoing packets should be given priority over other packets to prevent congestion on the ingoing and outgoing pipe" [HahnLitan06, p. 4]. I believe the authors are referring to section 4.4.1., as the word "incoming" only appears in a handful of places in this RFC, and only once in any context related to priority:

From the standpoint of controlling buffer congestion, it appears better to TREAT INCOMING PACKETS WITH HIGHER PRIORITY THAN OUTGOING PACKETS.

The all-caps are in the original. Hahn and Itan appear to have the capitalized part exactly backwards, which doesn't speak well of their conscientiousness, or that of the editors at the Milken Institute Review. However, that's not the deep problem. The deep problem is that Hahn and Litan do not understand what TCP is, and what is being described here.

First of all, TCP is an end-to-end protocol. Period. Every single normative sentence[1] in RFC 675 describes an operation that occurs on an end-host, not on a router internal to the network. The above sentence describes how an end-host should prioritize processing of packets in buffers inside its networking stack. It is, in other words, a hint to operating system implementors who want to write TCP/IP stacks. It has nothing whatsoever to do with "the network" prioritizing packets.

If this sounds like an abstruse distinction, imagine "the network" as the US Postal Service, and an end host as your home. The operating system's network buffer is your mailbox. What the above sentence is saying is that before you stuff outgoing mail into your mailbox, you should take your incoming mail out of your mailbox. It is saying nothing about whether the US Postal Service should pick up your mail in one order or another.

Does RFC 675 present a "sharp contrast to the romantic ideal of the end-to-end principle"?

It does not.

RFC 791

This RFC describes IP, the other fundamental protocol of the Internet. Again, the authors do not give exact quotes or specific citations, but they state:

A 1981 Request for Comments explained that precedence—a measure of importance of the data stream—could be used as a means of differentiating high priority traffic from low priority traffic.

Now, RFC 791 does contain some discussion of precedence. A "packet" is a little bundle of bits that a network shuffles around. Among other things, a network protocol must specify the form of its packets, just as the US Postal Service demands that envelopes be addressed and stamped in a particular manner. IP specifies a packet format with 8 bits reserved for the "Type of Service" field, which can technically be used to indicate the priority of a packet.

The motivation for this is as follows. Back in 1981, before the Internet emerged as the winner in the ecology of network designs, networking researchers were experimenting with different kinds of networks to run IP on. Some of those networks prioritized packets based on how the packets described themselves. It was believed that IP packets should reserve some space so that these networks could stash priority information in them. This reserved space is the "Type of Service" field.

RFC 791 does not describe how networks would use the "Type of Service" (TOS) field. That is specified in RFC 795, which describes how TOS is used by the AUTODIN II, ARPANET, PRNET, and SATNET networks.

None of those networks was the Internet. They were networks for military communications in the 1960s and '70's. None of them exists today. Now, as every geek knows, ARPANET was the ancestor of the Internet; but not all the features of ARPANET were carried over to the modern Internet. In particular, modern Internet routers do not use the TOS field, at least not as described in RFCs 791/795. Eliding many gory details, DiffServ (a.k.a. DSCP) supercedes TOS, and it is used for traffic shaping within individual subnets, not on the Internet as a whole.

In short, the section on precedence in RFC 791 describes a mechanism that is not, and has never been, used to prioritize packets on the Internet.

Does RFC 791 show that "prioritization has always been considered an important design characteristic for TCP/IP"?

It does not.

RFC 1633

RFC 1633 is, as noted above, a position paper by a group of distinguished networking researchers: R. Braden, D. Clark, and S. Shenker. In this RFC, Braden et al. argued (in 1994) that at some point in the future, a QoS mechanism should be adopted into the Internet's fabric.

Considered as a technical question, this is a controversial argument, but not a ludicrous one. I could discuss it at some length (and, if I ever get my act together, perhaps someday I will do so in this space), but for the moment I must focus on this RFC's relevance to Hahn and Litan's white paper. Hahn and Litan cite this as an "early writing on the Internet" that indicates that "prioritization has always been considered an important design characteristic of TCP/IP". There are at least two problems with this reading.

First, a document dated 1994 cannot be an early writing on the Internet. In June 1994, the Internet had not become a commercial mass phenomenon --- that had to wait for the spread of Netscape --- but it had existed for almost a decade. And, indeed, RFC 1633 sketches a speculative protocol extension to the existing Internet that has not, to date, been adopted by anybody.

Second, and more importantly, here are a few direct quotes from RFC 1633, Section 2:

The fundamental service model of the Internet, as embodied in the best-effort delivery service of IP, has been unchanged since the beginning of the Internet research project 20 years ago [CerfKahn74]. We are now proposing to alter that model . . .

. . . Internet architecture was [sic.] been founded on the concept that all flow-related state should be in the end systems [Clark88].

Designing the TCP/IP protocol suite on this concept led to a robustness that is one of the keys to its success.

In short, the authors state exactly the opposite of what Hahn and Litan would have us adduce. End-to-end flow control was part of the "fundamental service model of the Internet" and "one of the keys to its success".

Does RFC 1633 show that the Internet presents "a sharp contrast to the romantic ideal of the end-to-end principle"?

It does not.

RFC 794

Best for last. This one's particularly hilarious. Hahn and Litan quote this RFC at length --- one of the few times they do so:

In packet switching systems, there is little or no storage in the transport system so that precedence has little impact on delay for processing a packet. However, when a packet switching system reaches saturation, it rejects offered traffic. Precedence can be used in saturated packet switched systems to sort traffic queued for entry into the system. In general, precedence is a tool for deciding how to allocate resources when systems are saturated. In circuit switched systems, the resource is circuits; in message switched systems the resource is the message switch processor; and in packet switching the resource is the packet switching system itself.

That's a fine excerpt from RFC 794. The problem is that RFC 794 describes AUTODIN, not the Internet. Do you use AUTODIN? Me neither.

Vint Cerf was a networking researcher. He and Bob Kahn tried lots of things. The fact that some of his projects used packet prioritization has almost no relevance to the fact that the one project that succeeded wildly was a neutral network with end-to-end flow control.

Does RFC 794 give us an "early writing on the Internet"? Does it show that "prioritization has always been considered an important design characteristic for TCP/IP"? Does it demonstrate the Internet's "sharp contrast to the romantic ideal of the end-to-end principle"?

It. Does. Not.

Conclusion

The above points become apparent to anybody of moderate technical knowledge who attempts to read the RFCs carefully and understand them. RFCs were frequently written by Ph.D.'s, but they were not written for Ph.D.'s; they were written for hackers.

It is, perhaps, understandable that Hahn and Litan --- two economists --- could not understand these RFCs in detail. However, they have misread the RFCs so completely that it is almost inconceivable to me that they could have consulted someone with the necessary background.

They construe RFC 675 --- a description of an end-to-end transport protocol --- as a blow against the end-to-end principle. They construe (portions of) RFCs 791, 1633, and 794 --- documents which do not describe the Internet --- as documents describing the foundational principles of the Internet. In some cases, as with 1633, they cite these documents in support of a claim that is specifically refuted by plain text in the document.

How could this happen?

I would guess that Hahn and Litan's "research" process went something like this. First and foremost, they knew that they wanted to produce a paper arguing against network neutrality regulation. They had heard somewhere about these "RFC" things, and they knew that Vint Cerf, one of the current big pro-neutrality voices, had written a bunch of them. So, they decided to go search for the words "precedence", "priority", and "quality of service" in the old RFCs. To their great delight, these words appeared in some RFCs by Cerf himself, and by other prominent networking researchers. Alas, these technical documents turned out to be pretty tough to interpret if you've never written a line of networking code in your life. However, never mind meaning or context: knowing their "research" community --- economists predisposed to disliking regulation --- they figured they could get away with fudging the citations anyway, because none of their peers would understand the RFCs either. Most of them wouldn't even bother to try. So they went ahead and wrote their paper, and got it accepted to a little economics review.

Now, I understand that this is a pretty nasty thing to say. Given Hahn and Litan's long and distinguished careers in academia and public service, I would like to believe something else, but I'm having trouble doing it. I mean, look at the evidence above. They have clearly leaned upon the facts, as the proverb goes, as a drunkard leans upon a lamppost: for support, not illumination.

At best, I can understand this behavior as a combination of ignorance and arrogance: maybe the authors believed their vast experience in parsing documents in economics and law made it unnecessary to consult experts in computer science ("Not even a real science --- it has 'science' in the title!"). At worst, though, one could argue that it's a mixture of intellectual dishonesty and irresponsibility.


In Part 2 (if I ever manage to write it): Hahn and Litan's errors regarding VPNs and World of Warcraft.


[0] I normally ignore anything that comes out of AEI, as it tends to be 99% worthless on technology issues, and it's more work than it's worth to sort the wheat from the chaff. Based on Tim's decision to post about this paper, I waived my normal skepticism, and was pretty badly disappointed. Sigh. I have adjusted my priors, as the Bayesians say.

[1] By "normative sentence", I mean one stating a property that a TCP implementation must have in order to be rightfully called a TCP implementation. Now, like most RFCs, 675 is not an ultra-terse mathematical specification, but a document intended to be a useful and readable guide to practical implementors. So, it gives some background about routers and such to provide the reader with context. But as Cerf and Kahn state, TCP makes almost no requirements of the underlying network beyond its ability to carry bits, which is one reason why it works over substrates ranging from circuit-switched telephony (dial-up Internet) to the postal service.

Friday, November 17, 2006

Amdahl's Law and single parentood

More evidence that Ezra Klein's a bright guy: Observe as he uses Amdahl's Law to eviscerate the conservative contention that attacking single parenthood is the way to attack poverty.

Well, OK, he probably didn't know there was a name for that principle. It is a simple principle, but pretty central to thinking about any optimization problem.

Tuesday, October 17, 2006

Two TLF quickies: social organization; prisons

One:

Tim Lee, who is rapidly proving himself one of the most unconventional (and hence interesting) libertarian bloggers, writes about markets, firms, and governments:

The central insight of [Yochai Benkler's paper] Coase's Penguin was that peer production is a form of economic organization on par with the market (first explained by Adam Smith) and the firm (first explained by Ronald Coase). Benkler expands on this tripartite classification of organizational structures in The Wealth of Networks. He spends quite a lot of time pointing out that non-market, non-firm methods of social organization account for a substantial fraction of our economic lives. We carpool, have dinner parties, give directions to strangers, help each other move, etc. These activities generate goods and services (meals, rides to work, information) that could also have been obtained via the market, but for a variety of reasons we sometimes find that non-market organizational methods meet our needs better.

I think this is a point that libertarians tend to under-appreciate. . . .

The whole post is worth reading (some decent comments too), but I want to focus on one particular part:

Progressives often think the state can convert market forms of organization into non-market, non-firm, social organization. But they're wrong. When the state gets involved, it almost always imposes a centralized, bureaucratic structure--a "firm" form of organization, in Benkler's parlance. A lot of progressive may laud the potential of public schools to create communities, but in practice, the public school system is every bit as soulless and alienating as the largest corporations. Folks on the left should hate the New York public school bureaucracy for all the same reasons they hate Wal-Mart.

This is true to a first approximation. However, I think it lumps too many kinds of "firm" together. For example, the National Science Foundation's formally a government agency, and it operates like a hierarchical "firm" in the sense that you can pull out an organizational chart and say Alice reports to Bob, who reports to Carol, who reports to Dave, etc. In another sense, however, the NSF is more highly decentralized than almost any "firm" operating in the actual market: essentially all of the NSF's "product" (i.e., scientific research) gets outsourced to universities, and a large fraction of that goes directly to individual researchers [0]. Even the job of choosing which research grants get funded is outsourced: grant proposals are reviewed for funding by committees of independent scientists.

So is the NSF truly a "firm"? Is it a "market"? A "commons"? It's hard to say. If you want to break it down, you might call it a firm (the NSF agency bureaucracy) that uses a commons/reputation economy (grant committees) to allocate resources to individual entrepeneurs (professors) who work within quasi-feudal federations (universities) of guild chapters (academic departments). Yet the NSF and its partners constitute one of the most successful forms of social organization ever devised: considered together NSF, DARPA, and the NIH may be responsible for catalyzing more basic scientific research results than any other institutions in human history. [1]

Although it may be useful to use the tools of management theory, economics, or political science to analyze the workings of this confederacy of institutions, it would be misleading to label it a market, a firm, or a commons.

More generally, although it's possible (with some intellectual contortion) to divide the economy into the "public" and "private" sectors, the institutions in each sector take radically different forms that depend on a myriad of forces (including social norms and "architecture", the other two modalities of regulation in Lessig's four-cornered graph). It could be argued that the public/private distinction often isn't the most useful discriminator when thinking about whether some form of social organization is better or worse for any particular purpose.

I would therefore characterize the progressive tendency to seek solutions in government intervention as simply a reflection of their willingness to seek solutions to problems, period. Is the market not serving a need? Maybe we should see if the government can do it. Maybe we should see if the formalized nonprofit sector can do it. Maybe we should see if peer production can do it. Maybe we should start a business. Progressives probably err on the side of too much hope for all of these, but the median libertarian seems to err on the side of dismissing all but the last as either futile, pointless, or simply immoral.

(Aside from all of the above, of course, a whole other justification for government action arises from the fact that coercive state action can sometimes solve collective action problems. But I'd rather not get into that today.)

[0] Who are, of course, then "taxed" by the university bureaucracy for overhead.

[1] Granted, these institutions have had more resources than any other scientific organizations in history, but I think we got our money's worth.


Two:

Adam Thierer asks why child molesters get out of jail with such short sentences. As others have noted before, the criminal justice system sets sentences based on the available capcity of prisons. According to Bureau of Justice statistics, 21% of our current prison population consists of drug offenders --- not drug-related violent crimes, which would drive this number way up, but drug trafficking, possession, etc. --- and that's trending upwards over time.

The "War" on "Drugs" wastes enormous resources that could, among other things, be used to protect children from sex criminals. Unfortunately, this kind of point's pretty tough to get across in political debate, and I can already hear in my head the shallow sound-bite rejoinder: "We don't have to choose between protecting our children from drugs and protecting them from sexual predators. We can do both:" ---pause for applause--- "we can build more prisons."

Of course, barring some revolution in incarceration policies, any more prisons that get built will be populated by roughly the same proportion of drug (and drug-related crimes) offenders, making prison-building a fantastically inefficient way to provision for improved incarceration of sex offenders. But now we're entering the territory of points too subtle to make effectively in, say, the paltry thirty seconds that were allocated for rejoinders in our last Presidential "debates". The American people might understand it, but the news media would caricature you as a wooden, uncharismatic policy wonk (if you said it calmly) or a ranting nut case (if you said it with passion). The exchange itself would last less than five minutes, but the columnists and talking heads would be repeating their talking-points caricature of it for weeks.

Thursday, June 22, 2006

Market share, market power, and network neutrality

J. Gattuso writes about a recent proposal by James DeMint (R-SC):

Submitted as an amendment to the telecom bill now being marked up by the Senate Commerce Commitee, DeMint’s proposal would make it unlawful to “prioritize or give preferential or discriminatory treatment in the methodology used to determine Internet-search results based on an advertising or other commercial agreement with a third party.” Any person found in violation would face a maximum fine of $5 million or imprisonment for up to one year.

...

For the record, this is a terrible idea. And, I’m willing to bet that Sen. DeMint thinks so too. Instead, the amendment seems intended to underscore Google’s uncomfortable position in the net neutrality debate. While the company has spearheaded the call to for net neutrality for telephone and cable firms, its own practices — and power — mirrors that of those companies.

...

Google’s business model to a large degree is based on tiering — providing preferred ad placement for those who can pay for it. Its clearly not a system where anybody “no matter how large or small” has equal access. Its based, like it or not, on money.

None of this matters, says Google. There’s a big difference, it says, between its actions and those of the "phone and cable monopolies." But is there? The phone companies and cable companies do have an overwhelming share of broadband connections. But market shares in the search engiine market aren’t dramatically different. Three firms — Google, Yahoo and Microsoft — account for 84 percent of all searches. Ninety-five percent of “toolbar” searches are by two firms, Google and Yahoo. Of course, this companies aren’t in lockstep — they compete among each other. And they may be challenged by newcomers, who now have small market shares. Yet, the same arguments, when raised regarding broadband networks, are rejected.

This certainly doesn’t mean that Google should be regulated. Or that it will be. Yet, there are some who have seriously proposed the idea. And once lawmakers start imposing mandates, its hard to predict where they will stop. Once network owners are regulated, it simply wouldn’t be that big a step to regulate other Internet players, starting with the biggest. Sen. DeMint’s proposal may not be meant to be taken seriously. And this week it won’t be. But someday, thanks in part to Google, it could.

First, let us dispose of the "universal slippery-slope argument" against regulation, which goes like this: "If you regulate X, what's to stop you from regulating Y?" This statement can apply to arbitrary X and Y, and is therefore not a serious argument against anything. Gattuso does not make exactly this argument (though he slides perilously close in the final paragraph), but stating the universal version illustrates the obligations that Gattuso must discharge in order to make his case.

A reasonable slippery slope argument must place a bound on X and Y, and then make the case that this bound is the necessary distinction. In other words, you need to say:

  1. "If you admit that X is regulable because X satisfies the property P, then Y is also regulable because it also satisfies P."
  2. "P is the only reasonable distinction in this case."

The second clause is necessary because otherwise, your opponent can simply propose a different (and better) bound P, which excludes Y while including X. In the course of his essay, Gattuso proposes the following two P in order to substantiate his slippery-slope argument:

  • P(X) = "X is an 'Internet player'"
  • P(X) = "X has sufficient market power that it is not subject to strong competitive pressures."

I think it is transparently obvious that the first of these is not a relevant distinction; "Internet players" is a category so broad and vague as to be analytically useless.

However, the second bullet point deserves some consideration, because it is also the distinction that network neutrality advocates propose. Distilled to its essence, Gattuso's argument is as follows:

  1. The justification for regulating telecom companies is that their market power insulates them from competitive pressure.
  2. Google, Yahoo, and Microsoft have large market share.
  3. Therefore, Google, Yahoo, and Microsoft also have market power insulating them from competitive pressure.
  4. Therefore, by the same reasoning, one should be able to regulate search engines.

Notice that between steps (2) and (3), the above argument jumps from market share to market power, effectively conflating the two. But market share is, at best, an indirect proxy for market power. Market power depends on a number of factors, but in the end two overarching factors dominate:

  • Barriers to entry: How hard is it for competitors to get started in the market?
  • Switching barriers: How hard is it for buyers to switch between sellers of the good in that market?

These are the two factors that determine how easily somebody can start competing with you, and how easily you can lose your customers to the competition. If anybody can start up a competitor and all your customers can flee overnight, then you're in a competitive market. If it takes many man-years of labor, political connections, and billions of dollars of capital to start a competitor, and it will cost your customers a lot of time and money to switch, then you're not in a competitive market.

High market share does not necessarily mean that a seller has market power. Google might be the most popular search engine because it has tremendous market power which insulates it from competition, or it might be the most popular because it simply provides a better product in an efficient and competitive market.

So, let's consider the barriers to entry and switching barriers in the search engine market, and in the telecom market.

Stop laughing.

OK, perhaps some of you are not already laughing, in which case I will have to explain it. If you want to start a new search engine, all you have to do is download Nutch, hire a programmer to customize it for your needs, and put it on the web. If you want to switch from one search engine to another, all you have to do is type a different URL into your location bar.1

Of course, I'm being slightly disingenuous here. If you want people to use your search engine instead of the competition, it will have to be significantly better, in some way, than what people use today. And that will be pretty hard. But that's also a feature of competitive markets, so that does not, in itself, indicate market power.

Contrast this with broadband Internet access. Let's take barriers to entry first. How hard would it be for me to start a new broadband Internet provider that competes with cable and DSL? I don't know the details, but I'm pretty sure it would involve either (1) enormous capital outlays to dig trenches and lay down wire, and also possibly schmoozing with municipal officials to get permission to do these things, or (2) taking advantage of "common carrier" regulations that James Gattuso and other pro-telecom pundits despise.

Now let's take switching barriers. How hard is it to switch broadband providers? OK, in most U.S. jurisdictions you can do it, but it will take you a few weeks of waiting, several hours of your time, and on the order of a hundred dollars. And you won't be able to choose from any of dozens of providers, as you can with a search engine; you've probably got two choices (aside: if you're willing to assert that two choices provides "sufficient competitive pressure to produce an efficient outcome", then I will assume that you'd also be happy with a political system in which you are legally obligated to vote for a Democrat or a Republican. You've got two whole choices, after all!).

In case the foregoing has been too verbose, here's the ten-second recap:

  • Search engine market: ten days to start a new search engine, ten seconds to switch search engines, dozens of search engines available to most consumers.2
  • Broadband Internet market: years to start a new broadband provider, weeks to switch broadband providers, two providers available to most consumers.

Which looks more competitive to you? Do these two markets look even vaguely similar?

So, we see that Gattuso's slippery slope is not, in fact, slippery at all. Google, Yahoo, and Microsoft do not have the same kind of market power that broadband Internet access providers do. (Microsoft, however, does have a very different kind of power arising from its outsized market share in the operating system market, but I don't want to get into that in this post.) Given the property that he suggests, a strong distinction can still be made between search engine providers and network carriers.

Finally, as an aside, I'd like to note that a few weeks ago, shortly after my post on network neutrality, I received PR spam written by a telecom flunky named Scott Cleland and distributed by Peter Klaus of Fleishman-Hillard public relations, containing much the same argument as that espoused by Gattuso above. I am not suggesting that Gattuso is a mouthpiece for Fleishman, but I do want to suggest that this talking point --- conflating search engines' market share with anti-competitive market power --- is going to see wider circulation in the future.


[1] Oh, is everybody using Firefox with the default search engine? (And by "everybody", I assume you mean "roughly 10% of all Internet users", because that is the current number; and Google's definitely not the default search engine for Internet Explorer.) All you have to do is hire a programmer to download the Firefox source, change a couple of configuration files, and rebuild it, and now you've got a browser with the search box pointing to your search engine. Or, even better, it's easy enough to distribute a Firefox extension that people can install in their search box with a single click.

[2] I am pretending, here, that Google's users are its customers. Of course, most of Google's users are not customers; its real customers are advertisers, which suggests a somewhat different analysis (although not necessarily different conclusions). However, Gattuso and DeMint both initiated this "users are customers" fiction and I'm going along with it for now.

Sunday, May 21, 2006

Notes on network neutrality

So, "network neutrality" has been getting lots of press lately. Briefly, network neutrality is the principle that Internet carriers should provide "dumb pipes" that carry all Internet traffic equally, rather than discriminating based on the type, content, or destination of the traffic that flows across their networks. A wide array of interests --- including MoveOn, Google, and a number of other groups and companies across the political spectrum --- have been lining up behind initiatives to codify this principle in law for US Internet carriers. The principal opposition to the coalition comes, unsurprisingly, from two quarters: the telecommunications companies, and libertarians.

My reaction to this is twofold. My first and predominant reaction is: I am troubled by the idea of getting the FCC involved in regulating how Internet service providers architect their networks. The Internet actually works pretty well these days, so it seems dangerous to get Congress monkeying around with its guts. And the question of what constitutes a "neutral" network is pretty subtle, as the term has no widely agreed-upon technical definition.

In the absence of a technical consensus, the output of the legislative process is likely to be either a mishmash of mistargeted micro-regulations, or a vague and overly broad mandate for the FCC. Who knows what will come out of that process, but in my opinion the most likely outcome is simple regulatory friction that slowly, invisibly eats away at network innovation. Network innovation won't go away, but certain kinds of innovation will become more difficult because of legal complications, and the Internet will suffer. Therefore, I suspect that any legislation written today will hurt the Internet more than it helps. It is with some surprise that I find myself agreeing with the telecom giants and the Cato Institute, and disagreeing with MoveOn, Google, etc. If network neutrality regulation passes now, I think progressive activists and technology companies alike will live to rue the day they begged for it.

My second reaction is that this whole debate strikes me as a kind of bizarre ritual theater in which people are making noises and gesticulating wildly, but nobody talks about the real issue.

Political outfits --- ranging from MoveOn to the Christian Coalition --- are worried that network providers will begin to discriminate based on the political content of messages. This is pretty unlikely. It's not easy for an algorithm to look at a bag of bytes and classify its political content; and network providers probably can't pay for the computational power required to apply such an algorithm to the many terabytes of data that flow across their networks daily.

And even if they could, why would they? There's no percentage there. In fact, I can think of two very strong reasons for them not to start filtering based on political content. First, there would be an enormous consumer backlash. Second, there would be enormous political fallout. The latter would include not only backlash against abuse of quasi-monopoly power, but possibly the imposition of responsibility for the content that flows across the pipes. Once you begin filtering based on political content, lawmakers may poke their heads in and wonder why you aren't filtering out all that kiddie porn and gambling and such too --- and if something gets through your filters, why can't we hold you liable? The network providers don't want to open that can of worms.

So, political censorship isn't the real issue here. Nor, pace Moby et al., is it interconnection with small media providers versus large ones. Verizon's not terribly likely to block access to your music blog. They might, someday, contract with certain service providers for improved performance. For example, they might strike a deal with iTunes to store songs in a local proxy cache, so that Verizon customers would observe slightly improved performance with iTunes, but not your music blog. That doesn't strike me as either disastrous or a betrayal of the Internet's principles. Networking researchers have been proposing schemes like this for years. In fact, Akamai's basically a third-party version of this scheme: people pay them to store content in caches close to where it's demanded, so Akamai-cached websites perform better than non-Akamai websites. Akamai's been operating since 1999, and so far the Internet hasn't been torn asunder.

So what's the real issue?

As Ars Technica noted back in January, Verizon CEO Ivan Seidenberg was making noise about Google's (over-)"use" of Verizon's bandwidth. And last November, SBC CEO Edward Whitacre complained about Google and Microsoft using "my pipes" (meaning, of course, SBC's pipes; Whitacre suffers from your usual case of CEO megalomania):

"So there's going to have to be some mechanism for these people who use these pipes to pay for the portion they're using. Why should they be allowed to use my pipes?"

In a way, you have to give Seidenberg and Whitacre credit. In making these noises, they display a level of stupidity and chutzpah that rivals the dudes from Jackass.

First, the chutzpah: Google does pay its ISP for its Internet connectivity, just as Verizon customers pay Verizon for their Internet connectivity. Yet Seidenberg claims to believe that Google should pay Verizon for the Internet connectivity that Verizon's customers have already paid for. It's as if Ford were to ask Wal-Mart to pay fees to Ford, because Wal-Mart's customers were driving to Wal-Mart in Fords.

Second, the stupidity: five and a half months later, Verizon's lobbyists are working overtime to prevent network neutrality legislation from passing. And guess who's paying for the lobbyists on the other side? In many ways, Seidenberg, Whitacre, and their telecom industry cronies brought this circus on themselves through overreaching arrogance and greed.

So, here's the real story. The telecom giants currently sell you Internet access, which is okay, but dull. Dumb pipes are cheap. But hey --- what if they could sell you lots of bundled services? That really gets the dollar signs flashing in their eyes. These are the companies that want to sell ring tone subscriptions for your cell phone, and bundled cable packages with more channels than you'll ever watch. Their dream is to add a dozen extra bullshit services to your Internet service bill, so that you're paying them eighty dollars per month instead of fifty.

The big problem with that plan is that once you have dumb pipes and smart endpoints --- in other words, the Internet --- the endpoints can build essentially any service on top of the network. Of course, this is fantastic for Internet users. Once you pay for Internet access, you automatically get to use every Internet application that's ever been invented: email, the web, instant messaging, peer-to-peer, and (increasingly) the two V's, voice and video. These last two really drive the telecom giants nuts, because they used to sell you voice and video: they're phone and cable companies.

Therefore, the most likely form of telecommunications discrimination in the foreseeable future is discrimination by application, not by content. Verizon wants to give preference to its voice services, and Comcast wants to give preference to its video services. They're deeply freaked out by Skype, Google Video, and the like. If they can convince customers that competing services are slow and crappy compared to their own offerings, they think they'll have a better chance of getting you to pay for their bullshit services. Failing that, they'd like to convince Google and other Internet companies to pay fees for non-degraded service. Think of it as protection money: "Nice customer base you got there. Sure would be a shame if your packets were dropped 20% more often than your competitor's..."

If network providers got serious about this, the results would be pretty bad. Network providers should not be picking winners and losers in the Internet applications game. Applications should succeed or fail on their own merits. Now, I think network discrimination schemes would fail in the long run, but that's just a hunch and it's really an open empirical question. Meanwhile, in the short run, discrimination schemes could cause major distortions in the Internet applications market; and when you consider the possible network effects in domains like Internet telephony, it's possible that these distortions could cause lingering damage, locking in inferior applications for years to come.

So I'm really glad that people are paying attention to network neutrality. But I'm also alarmed that so few of those people seem to understand what's really going on here, and I'm skeptical that now is the time to make laws about it. So far, the Internet's still neutral. My bottom-line recommendation would be to watch and wait.

(And also to increase competition in local ISP markets, which would give customers a choice when confronted with discriminatory network policies. Note that this wouldn't be a panacea, because in practice most localities would still be served by a few providers, each of which might have an incentive to discriminate, albeit in differing ways. Oligopolies don't necessarily lead to efficient markets.)


p.s. Selected links on network neutrality:

Saturday, March 25, 2006

Barbara Bogaev's weak interview with Surgeon General Richard H. Carmona

On Weekend America's show today, the hostess Barbara Bogaev completely dropped the ball in an interview to U.S. Surgeon General Richard H. Carmona. At one point in the interview, after several long minutes of giggly fawning over Carmona's time as a police officer and Army special forces member, the following subject came up:

Bogaev: Well, I was thinking, from your background, that you would be a pretty flamboyant Surgeon General, you know, that you would follow along the lines of Dr. C. Everett Koop or Dr. Jocelyn Elders, who spoke out, either about sex or smoking or educating the public about AIDS, that you would take that tack, but you haven't, really. You've been much less in the public eye. Why do you think that is?

Carmona: Well, I do speak out, and I guess if you, for instance, if you Google me, you'll find a few hundred thousand hits there, and, it's---.

Bogaev: Oh, believe me, I did. But you don't seem to be going for controversy. Which I might have expected, from a former SWAT guy.

Carmona: I think you have to know when to fight your battles. You have to live to fight every day and another day. And I find I am able to be very effective behind the scenes. Going out and making a big stand on something may be the right thing to do sometimes, but at this point I haven't been challenged with anything like that. My predecessor, and good friend, Chick Koop, dealt with the AIDS thing, and I've spoken to him many times. I said Chick, what drove you at that time? He said, "When I saw people, elected officials, using their bully pulpit and distorting the science for political ideology," he said, "I was forced to stand up." And that was extremely controversial at the time. Now, I'm not looking for that, but if something crossed my threshold that I felt I needed to stand up and be that vocal and outspoken, you bet I would.

Bogaev: So that hasn't happened yet, you're saying.

Carmona: It hasn't.

Bogaev: Your sense of moral outrage hasn't been provoked yet.

Carmona: Well, my sense of moral outrage has been, on some occasions, but I back off and I look, and I say what's the best path. Is a big press conference and a lot of fanfare gonna do anything, or is that gonna die out in a couple of days?

Bogaev: You know, you're serving in an administration, though, that has been accused of being hostile to science, on issues like stem cell research and global warming, and the teaching of evolution. On a whole range of issues.

Carmona: [pause] I've heard the accusations.

Bogaev: Yeah, what do you think of that?

Carmona: I'm not gonna use the word hostile. I've spoken to my colleagues on both sides of the aisle, as it relates to a number of scientific, uh, issues. Certainly, as I move through life as Surgeon General, I look at the scientific merit, and that's where I have to stay focused. I do the best I can to stay out of the political fray, which often is less about science and more about political ideology or theology. That's not my job.

Now, if you're a journalist, what's the natural followup question? If you're not even trying very hard, and you're even vaguely aware of the medical controversies facing this nation, perhaps you'd come up with one of the following:

  • Most of the medical research community believes that the current supply of stem cell lines in the United States is insufficient for research purposes. The Bush administration disagrees. Do you feel that it is scientifically supportable to claim that the current supply of stem cell lines is sufficient?
  • Merck has an HPV vaccine with astounding, slam-dunk clinical trial results. Addition of this vaccine to the standard vaccination regime in schools would eventually save thousands of women from cervical cancer every year. Republicans in Congress are blocking adoption of the vaccine. Could you speak to the merits of the vaccine, as a public health policy matter?

Guess what Bogaev asked Surgeon General Carmona?

Bogaev: Well, Dr. Carmona, I know you have to get going. I understand you have to go pick up your kids. So just one last question. Do you ever let your children eat fast foods?

A hearty golf clap for you, Ms. Bogaev.

Monday, March 20, 2006

On the draft

Jo-Ann Mort at TPMCafe revisits the notion of conscripted national service, using the standard argument that universal service will make it politically harder to send people to war. This issue keeps cropping up from time to time in liberal intellectual circles. I'm not sure exactly how I feel about a draft, but I have three comments.

First, I find the spectacle of middle-aged pundits advocating a draft for young people rather suspicious. It reeks of the same somebody-else-pays mentality that the draft supposedly eliminates. If we're going to have universal national service, then let's make it really universal: make everybody eligible for the draft, except for retirees and people who have previously served. The military's so-called "tooth-to-tail" ratio --- i.e., the proportion between the number of "tooth" soldiers serving on the front lines, and the logistical "tail" that supports them --- is something like one to seven. There are plenty of support occupations, both stateside and overseas, that don't require great physical exertion. Anybody of reasonably sound mind and body could fill those roles, not just the young. This becomes even more true if we adopt the proposal, favored by many liberal draft proponents especially, that national service could encompass civilian service.

I don't really buy the usual arguments for drafting the young only. Do older people have careers that might be interrupted? So do young people, who often have once-in-a-lifetime opportunities that they'd be forced to pass up; consider what would have happened to Sergey and Larry if they'd been drafted in 1997, when they were in their mid-twenties. Do older people have families to support? So do many of the younger people who'd be drafted (a point that may be lost on pundits because children of the mandarin class tend wait till they're approaching thirty). And is it better for a parent to be absent when the child's learning to speak than when the child's in high school? Six of one, half-dozen of the other, it seems to me.

Furthermore, all the arguments for universal service for the young become even stronger when you expand the draft to all ages. It will be even harder to go to war, because an even larger fraction of society will be affected. Society will benefit even more, because there will be even greater mixing, not only among social classes but between generations.

Now, I've elided some distinctions here, and I should un-elide them. One can envision two forms of universal service. First, one could have a deterministic universal service requirement, akin to what Israel currently has --- i.e., mandatory national service, at a certain age, for everybody in society. Second, one could have probabilistic universal service, which is what happened to people 18-25 during the Vietnam draft --- i.e., you live your life as usual, and someday your number might come up. My proposal above, for universal service for all ages, could be interpreted in several ways:

  1. Adopt deterministic service, but use probabilistic service as a transitional proposal to "grandfather in" all the people who never had to serve.
  2. Adopt probabilistic service for all time; this proposal comes with two variations:
    1. Permit everyone to avoid the draft by volunteering anytime before their number comes up.
    2. Disallow some fraction of people born in each year from volunteering before their number comes up.

Proposals (1) and (2a) are relatively self-explanatory, and would probably work out fairly similarly in practice. Most people would take their service early in life, and at a time chosen so that they could control the disruption involved, in order to avoid being hit by an unpredictable draft.

The final sub-option --- disallowing some people from volunteering --- is, I think, the most interesting. The reasoning goes like this. When only the young serve, the burden of war falls disproportionately on the young. (Yes, people have families, but still, going to war personally is an even greater life disruption than sending someone in your family to war.) This disadvantage still holds when service is universal: although everyone serves, the current cohort of older people at any given time knows that it will not have to serve in any war that society undertakes. Therefore, one should always "hold back" some people from every cohort, preventing them from taking their service when they're young, so that every age group contains some people who might be drafted in any given war.

Next, my second point. Some people will always be able to avoid dangerous combat, one way or another: witness G. W. Bush and the National Guard. The point of a draft isn't to institute perfect universal service, but to drive a wedge between the extraordinarily well-connected and the merely well-to-do, or in other words between the top 0.1% and the top 2%, a split that (sadly enough) would have huge consequences for American politics. I confess I'm not entirely comfortable with using human life and death as a political instrument, but I also suspect that my analogues speaking for the top 0.1% don't feel the same squeamishness.

Finally, my third point: instituting a draft doesn't mean being forced to fight in unjust wars. Even if a draft were instituted, you would always have a principled way to avoid fighting in a war that you oppose: go to jail. That may not sound like much of a choice, but as a protest of last resort, it is always available.

Sunday, October 30, 2005

Sensible countermeasures against mass casualty terrorism

I've pointed several times, in this forum, to a multi-institutional course about cybersecurity and homeland security that's being offered this term at UW, UC Berkeley, and UCSD. One of the things that comes up in the lectures (video and slides available online) is that there are, in fact, many simple measures that would mitigate the casualties from chemical, biological, radiological, and nuclear attacks.*

It's commonplace, especially among conservatives, to say stuff like "you won't win the war on terrorism with defense --- you have to go on offense!" This is true, as far as it goes: in an open society, it's not feasible to defend every target against terrorist attack, which means that you can only prevent mass casualty terrorist events by using a mixture of diplomacy, intelligence, law enforcement, and military action. But this can't be an excuse for neglecting defensive measures, some of which would do considerable good.

For example, taking refuge in fallout shelters, even very crude ones, considerably mitigates the damage of a nuclear attack. Nuclear explosions kill people within a certain radius through raw blast force and heat, and there's not a whole lot you can do inside that radius. However, outside that radius, you want to be insulated from radioactive fallout for about 48 hours (by then, the fatality rate from radiation poisoning has dropped dramatically --- the most dangerously radioactive elements of fallout are also those that decay most rapidly). You can avoid radiation pretty effectively by putting distance between yourself and the radioactive dust outside: either take refuge in a shelter with thick walls, or move deep into the central spaces of a large building (far from the exterior surface).

So why isn't the Dept. of Homeland Security telling people in major metropolitan areas to prepare fallout shelters, and take other defensive measures? UC Berkeley public policy prof. Steve Maurer makes a good point on the course wiki discussion for a recent lecture:

It turns out that if you do something minimal like dig a hole in the backyard and put a door on top of it, that cuts down the radioactivity pretty dramatically. That's just physics, there's not much doubt it's true. But the last time the government tried to point this out in a big way was during the Reagan Administration. The problem with this pitch -- they called it "with enough shovels" -- was two-fold. First "everyone knows" that we will all die in a nuclear war, so everyone translated "with enough shovels" as evidence that Reagan "must be senile." Second, people like to avoid thinking about nuclear war. Saying "the government should do something" does that, saying "we'll all die" does that, but saying "you are the first line of defense" asks people to think which makes them anxious. So what you end up with is physically sensible advice that people would desperately want to know in a nuclear war but will create a huge political backlash if you bring it up in advance.

Now, during the Cold War, the most credible nuclear threat was global thermonuclear war, i.e. massive numbers of fusion bombs dropped on every major population center in America. In that context, I think that "we will all die in a nuclear war" was actually not much of an exaggeration. However, in the post-Cold War, post-9/11 era, people generally believe that the most credible nuclear threat is a fission bomb (considerably less potent than a fusion bomb), stolen or manufactured by terrorist groups, and detonated in one city. In this context, American society would largely survive intact, but there would be many people in the attacked metropolitan area who have a good chance of either dying or surviving, depending on how they act. Some of those people will be downwind, in the path of the fallout plume; it's unlikely that we'll have enough road and transit capacity to quickly evacuate them all; and having plans to place people in fallout shelters would be a really good idea.

And fallout shelters are just one defensive measure among many. Biological attacks are even more subject to mitigation than nuclear attacks --- the behavior of carriers and potential victims can make all the difference in the propagation of an infection.

Why don't you and I already know about these countermeasures? Why don't we already know what to do in the event of a mass-casualty terrorist attack? Clearly, if America's political leadership were serious about defending America against terrorism, then undertaking a public education campaign would be part of their strategy, regardless of the political difficulty. Just as clearly, our leaders aren't doing this. Instead, we've gotten inscrutable color-coded "terror alerts" and vague exhortations to spy on our neighbors.

Of course, one can just add this to the long list of counterterrorism opportunities missed in the past four years. When you get down to it, our political leaders either haven't thought very seriously about counterterrorism policy, or else their thinking on the subject has been profoundly misguided, or both.

At this point, it would be incredibly easy, and appropriate, to segue into a broader rant against the ruling political party. But, I don't really have time to get into all that tonight, so for now I leave this as an exercise for the reader.


* Incidentally, of these four weapon categories ("CBRN"), the experts who've lectured in this course think that only biological and nuclear attacks ("B" and "N") have serious potential to be "mass casualty" events. The reasons are somewhat complicated, but in a nutshell:

  • It's hard for a terrorist to deliver chemical weapons in a way that causes hundreds or thousands of fatalities, as opposed to a few dozen.
  • The radiological attacks that terrorists are likely to be capable of executing don't generate piles of dead bodies. Rather, they increase the victims' lifetime probability of getting cancer by a few percent. This might have considerable psychological effect, but it's not a mass casualty event.